Incident

Minor Incident edudip.com
2022-10-18 11:00 CEST · 18 minutes

Update

Resolved

The services are reachable again.

October 18, 2022 · 11:18 CEST
Issue

Some parts of our services are not reachable at the moment.
Some parts like the Landinpage might not be reachable at the moment.

October 18, 2022 · 11:17 CEST

← Back