Viewing and downloading of recordings disrupted

Minor Incident Webinar-room Recordings
2023-04-27 10:00 CEST · 2 hours, 14 minutes

Update

Resolved

Viewing and downloading Recordings works again

April 27, 2023 · 12:13 CEST
Issue

Users are unable to view or download recordings. We are investigating the issue and working on a solution.

April 27, 2023 · 11:06 CEST

← Back