edudip GmbH Status
Subscribe
to Updates
Dial-in unavailable
Minor Incident
edudip.com
2023-07-17 11:05 CEST
· 13 minutes
Update
Resolved
The Dial-in is working again.
July 17, 2023 · 11:17 CEST
Issue
The dial in is currently unavailable
July 17, 2023 · 11:05 CEST
← Back