edudip GmbH Status
Subscribe
to Updates
Market not reachable
Temporary Incident
edudip.market (including sofengo.de and business solutions)
2023-07-19 16:59 CEST
· 43 minutes
Update
Resolved
Market is reachable again
July 19, 2023 · 17:13 CEST
Issue
We are currently investigating a disruption on the market platform.
July 19, 2023 · 16:59 CEST
← Back