Problems with our telephone provider

Minor Incident Hotline
2023-07-26 09:52 CEST · 1 hour, 59 minutes

Update

Resolved

Our hotlines are available again.

July 26, 2023 · 11:51 CEST
Issue

Our telephone provider is currently reporting issues their system. This may impact the reachability of our hotlines.

July 26, 2023 · 09:52 CEST

← Back