minor functional restriction of our E-Mail service

Minor Incident edudip.com
17 hours, 56 minutes, 53 seconds

Update

Resolved

the issue has been resolved.

June 29, 2020 · 09:56 CET
Issue

from Sunday evening until Monday morning we had a problem with our E-Mail service. Most E-Mails were delayed until Monday morning, but have been delivered since.

June 29, 2020 · 09:55 CET

← Back