Working on the mail server

Minor Incident edudip.com
2020-07-09 09:30 CEST · 1 hour, 7 minutes, 5 seconds

Update

Resolved

The issue has been resolved.

July 9, 2020 · 10:37 CEST
Investigating

Invitation E-Mails are being sent again, there might be delays.

July 9, 2020 · 10:14 CEST
Issue

An error in sending the invitation emails is currently being worked on. All other email functions are still available. The invitations created during this time will be sent after the issue has been resolved.

July 9, 2020 · 09:50 CEST

← Back