Mailserver down

Minor Incident edudip.com
5 hours, 50 minutes, 50 seconds

Update

Resolved

Der Mailversand funktioniert wieder.

September 22, 2020 · 20:20 CET
Issue

E-Mails are delayed right now, some may even not arrive at all. We are working on a solution.

September 22, 2020 · 15:16 CET

← Back