Elevated response times

Minor Incident next.edudip.com
2026-01-05 08:03 CET · 1 hour, 42 minutes

Update

Resolved

The issue has been resolved

January 5, 2026 · 09:45 CET
Issue

We are currently experiencing increased loading times when accessing webinars. A fix is already in progress.

January 5, 2026 · 08:03 CET

← Back