Restrictions on the use of our Service

Minor Incident Webinar-room Media-Servers
2021-02-10 10:00 CET · 54 minutes, 4 seconds

Update

Resolved

The problem was found and solved at the data centre in Frankfurt.

February 10, 2021 · 10:54 CET
Issue

Currently there may be restrictions in the use of our software. We are working on finding the cause and will inform you as soon as the problem has been solved.

February 10, 2021 · 10:12 CET

← Back