Problems entering the webinar room

Minor Incident Webinar-room Webinar-room
2021-05-26 08:43 CEST · 1 hour, 40 minutes, 12 seconds

Update

Resolved

The problem was located and resolved.

May 26, 2021 · 10:24 CEST
Issue

Currently, there may be problems entering the webinar room.

We are working on a solution and will inform you as soon as the problem has been resolved.

May 26, 2021 · 08:45 CEST

← Back