Increased loading times

Minor Incident edudip.com VIP API-access
2021-11-03 13:53 CEST · 4 minutes

Update

Resolved

The problems have been solved and www.edudip.com can be reached quickly as usual.

November 4, 2021 · 16:26 CEST
Issue

Currently there may be increased loading times on www.edudip.com.
Our development team is working on a solution.

November 4, 2021 · 16:26 CEST

← Back