edudip GmbH Status
Subscribe
to Updates
Market Down
Temporary Incident
edudip.market (including sofengo.de and business solutions)
2022-08-02 12:02 CEST
· 2 minutes
Update
Resolved
All systems are operational again
August 2, 2022 · 12:05 CEST
Investigating
We are currently investigating the issue
August 2, 2022 · 12:03 CEST
← Back